We are having a very brief cold start problem in this 911SC. After the car sits for about 8 hours, it struggles to start for a few seconds. Once it has started once, it will start immediately for the next 6-7 hours like everything is normal. Once it sits overnight, it struggles again. This makes diagnosing the issue very difficult, as you can’t tweak something, check it, tweak something else, check it. Instead you get one shot, then have to …

Read more »

Have this 2003 boxster in the shop right now for an IMS bearing upgrade. Another 19k mile car with a pretty bad oil leak underneath the car. The later cars can be a real bear to pull the transmission on. This car has the glass rear window, which severely limits access to the top of the engine bay (even for me), and it is a tiptronic, which means disconnecting the torque converter to the flex plate has to be done …

Read more »

Had this very early production 05 come in the other day for a window issue, brake fluid flush, and oil change. Draining the oil and of course installing a magnetic drain plug. And bleeding the brake system. This car had the typical “window goes back up after you release the handle” which makes closing the door a real pain, so a new door latch mechanism was in order. Unfortunately, the 997 is much harder to get to than the 996 …

Read more »

Installed a bunch of upgrades on this 2010 Turbo S this week. mmmm shiny. Fabspeed X-pipe exhaust, headers, and intake. First thing we needed to get rid of though was the K40 Calibre laser shifter system. And install something that actually works 🙂 Funky angle, but the heads are mounted in the front grill. Important to get them level and even with each other. ECU was reflashed to EVOMS software for a nice bump in hp and tq. The old …

Read more »

Tire Mounting

Track season must be upon us. I think we mounted/balanced about 8 sets of tire/wheel combos this week. Got some big 295’s mounted up on the rear of Johnny 5 so Val can do the KCRPCA ladies autocross on the 1st!

Been trying to get on top of the body work in preparation for paint. Not a lot of fun work 😉 Reassembled and aligned the hood so I could install the hood pins. All old factory latch components have been removed. Using the headlight mounting points, I welded some pipe to a piece of flat iron with two holes for the mounts, then welded a nut to the top that the adjustable pin threads into. Since the retaining nuts on …

Read more »

Since my last trailer went missing, I found a replacement here in KC. A 24′ featherlite open trailer should handle all my towing needs. First thing to do those, is to update all the lighting to Peterson LED lighting! They are just around the corner from the shop and make automotive lighting. I had updated the last trailer with their lights and it made a huge difference in trailer visibility at night! The old light bulbs. The previous owner of …

Read more »

With the warm weather upon us, this little boxster rolled in for a little spring maintenance. The passenger side headlight bulb was burnt out and the owner knew the bracket was broken to the headlight, so we ordered a new bracket so we could remove the headlight assembly, change the bulb, then get it back in to where it will hold. When I got it up in the air, I realized the exhaust was flopping around more than normal….not good. …

Read more »

Had this GTI in this week to diagnose a weird boost leak that it was having. Got it up on the lift and checked for the obvious loose hose connections of which there were quite a few. Snugged things down, then finally found the culprit. From underneath, I noticed a hose missing from the inlet of the turbo pipe. Not good. After a bunch of searching, I found it tucked behind a few hoses, so I reattached it and put …

Read more »

Had this little 951 towed into the shop the other day for a no start. Owner was trying to diagnose a cranking, but not firing issue when everything locked up solid. First thing we had to do was the replace the locked up starter. Enough cranking must have overheated it and locked it solid. Since there was no tach bounce and the owner had installed new reference sensors and DME relay, the first thing to try was the DME. Popped …

Read more »